Categories
Programming

After upgrading to 10.6.5, can’t run sudo apachectl restart

I got this error whenever I ran sudo apachectl restart starting after a recent upgrade to 10.6.5:

/usr/sbin/apachectl: line 82: ulimit: open files: cannot modify limit: Invalid argument

After this reading this post1, I changed /usr/sbin/apachectl line 64 from this:

ULIMIT_MAX_FILES=”ulimit -S -n `ulimit -H -n`”

to this:

ULIMIT_MAX_FILES=””

References
1. deversus.com

Leave a Reply

OR LOG IN WITH




Your email address will not be published. Required fields are marked *