Scan Your Site For POODLE Vulnerability

https://www.ssllabs.com/ssltest/